Hurricane Michael
Incident Report for etherFAX
Resolved
Tracking for this incident on the etherFAX status page has been closed. Please reach out to support@etherfax.net or sales@etherfax.net should you require any further assistance.
Posted 4 months ago. Oct 17, 2018 - 11:56 EDT
Update
We at etherFAX know that the devastation caused by Hurricane Michael surpasses anything we can imagine. The road to recovery will be a long one and we wish the best for all of those affected. We are going to close out this incident on our status page but please do not hesitate to reach out if we can do anything to assist during this recovery and rebuilding period.
Posted 4 months ago. Oct 17, 2018 - 11:53 EDT
Monitoring
Hurricane Michael is expected to make landfall along the Gulf Coast tomorrow. The etherFAX team stands ready to assist anyone that is affected by this storm.

If you need any assistance please email support@etherFAX.net and include 'Hurricane Affected' in the subject line of your request. Our team will be responding to those requests 24 hours a day and providing support to keep these vital services up and data flowing during this time. There are no expected storm threats to etherFAX infrastructure or data centers.

Stay safe!
Posted 5 months ago. Oct 09, 2018 - 10:01 EDT
This incident affected: U.S. API Services (U.S. REST Services, U.S. SOAP Services) and Analog to etherFAX (A2E) Device Services.