Major Allstream Outage in California and Nevada
Incident Report for etherFAX
Resolved
This incident has been resolved.
Posted Jul 22, 2017 - 15:19 EDT
Monitoring
etherFAX has been made aware of a large outage affecting Allstream customers (formerly Integra Telecom/Electric Lightwave). While this does not affect etherFAX directly, calls to affected numbers or originating from this carrier may fail due to the outage.
Posted Jul 21, 2017 - 15:15 EDT
This incident affected: Telephony (U.S. Inbound DID, U.S. Outbound).