Transactional Email Provider Experiencing Issues
Incident Report for etherFAX
Resolved
Provider has indicated that the issue has been resolved.
Posted May 17, 2018 - 12:53 EDT
Investigating
Please be advised that our transactional email service provider is encountering some connectivity issues at this time. Connection alerts, password reset emails, and other system generated emails may experience some delays in arrival to you. Emails to and from sales, support, and portability teams are not affected.
Posted May 17, 2018 - 12:47 EDT
This incident affected: Customer Portal and Reseller Portal.