Extended Support for Hurricane Irma
Incident Report for etherFAX
Resolved
This incident has been resolved.
Posted Sep 19, 2017 - 14:24 EDT
Monitoring
As preparations are being made throughout the southeast for Hurricane Irma, we at etherFAX wanted to share the preparations we are making to better serve customers affected by this storm. 

First and foremost, we hope that everyone remains safe throughout the storm. We recognize that for many of our customers etherFAX is a life-line service. We are making our support team available 24 hours/day throughout the duration of the storm for affected customers for both Hurricane Irma and those still being affected by Hurricane Harvey. If you need any assistance at all please email support@etherFAX.net and include 'Hurricane Affected' in the subject line of your request. Our team will be responding to those requests and providing whatever support possible to keep these vital services up and data flowing during this time. 

There are no expected storm threats to etherFAX infrastructure or data centers.
Posted Sep 05, 2017 - 21:12 EDT