Monitoring has continued to show positive metrics. This incident will be marked as resolved.
Posted Sep 04, 2025 - 22:11 EDT
Monitoring
ETHERFAX have continued to monitor calls and all metrics are looking normal. We'll continue to monitor closely for the next few hours.
Posted Sep 04, 2025 - 19:57 EDT
Identified
We are seeing partial restoration of services at this time. The team is continuing to monitor.
Posted Sep 04, 2025 - 19:43 EDT
Update
The ETHERFAX team is still working with carrier team to restore service.
Posted Sep 04, 2025 - 18:31 EDT
Update
Engineers are still working to identify the cause of the failures.
Posted Sep 04, 2025 - 17:21 EDT
Investigating
ETHERFAX engineers are currently engaged with a single carrier regarding inbound failures. This is affecting some US inbound DID numbers on the ETHERFAX platform.
Posted Sep 04, 2025 - 16:10 EDT
This incident affected: Telephony (U.S. Inbound DID).