Outbound Faxing Delays

Incident Report for ETHERFAX

Resolved

Engineers responded to metric alarms indicating some minor delays. After analyzing the logs, alerts, and the system performance overall the team determined that there was no impact.
Posted May 11, 2026 - 10:48 EDT

Investigating

Engineers are looking into some outbound faxing delays on the platform.
Posted May 11, 2026 - 10:35 EDT
This incident affected: U.S. API Services (U.S. REST Services) and Canada API Services (Canada REST Services).