Denver Telco Switch Outage

Incident Report for ETHERFAX

Resolved

Monitoring has continued to show normal call completions. We are going to go ahead and close this incident.
Posted Mar 23, 2025 - 21:36 EDT

Monitoring

ETHERFAX staff have worked with personnel inside data center to power cycle the equipment. It has returned to normal operation. Numbers have been rerouted around this issue and engineers are monitoring.
Posted Mar 23, 2025 - 13:46 EDT

Update

We are continuing to investigate this issue.
Posted Mar 23, 2025 - 13:22 EDT

Investigating

Engineers are currently aware of an issue affect a hardware switch in our Denver data center. The team is working to route calls off this switch to alternate paths.
Posted Mar 23, 2025 - 13:14 EDT
This incident affected: Telephony (U.S. Inbound Toll-Free, U.S. Inbound DID).