Hurricane Dorian | 24x7 Support Resources Available
Incident Report for etherFAX
Resolved
This incident has been resolved.
Posted 7 days ago. Sep 12, 2019 - 17:02 EDT
Update
Hurricane Dorian has continued strengthening and its forecast path has changed to now include the entire southeastern coast. The storm is expected to have direct effects for the week ahead. etherFAX will continue to maintain resources 24x7 throughout the week to handle any support requests.

Most of all we wish for all of those in the path of the storm to remain safe.
Posted 18 days ago. Sep 01, 2019 - 08:49 EDT
Monitoring
Support staff will be standing by monitoring inbound communication channels and ready to assist.
Posted 20 days ago. Aug 30, 2019 - 14:55 EDT
Investigating
Hurricane Dorian has been recently upgraded to a Category 3 Hurricane and will pose a threat to Florida and surrounding areas over the long weekend. etherFAX will make support resources available to those affected customers 24x7 throughout the storm in order to keep critical lifeline services operational.

If you are in an affected area and need access to etherFAX Support during the storm please email 24x7@etherfax.net and utilize the phrase "Hurricane Affected" in your subject line. You can also reach us via phone 8773849866, option 2. Please leave a voicemail letting us know you've been affected by the hurricane, your support needs, and the best number or method to reach you. We will reach back out to you ASAP.
Posted 20 days ago. Aug 30, 2019 - 14:51 EDT
This incident affected: Telephony (U.S. Inbound Toll-Free, U.S. Inbound DID, U.S. Outbound), U.S. API Services (U.S. REST Services, U.S. SOAP Services), and Analog to etherFAX (A2E) Device Services.