[US] Upstream Carrier Issues
Incident Report for etherFAX
Resolved
We are continuing to observe normal call completions from the affected upstream carrier. This incident is now resolved.
Posted Nov 30, 2021 - 17:56 EST
Monitoring
The upstream carrier has resolved the issue as of 22:15 UTC and we are continuing to monitor.
Posted Nov 30, 2021 - 17:22 EST
Investigating
etherFAX is aware of an upstream carrier issue affecting some toll DIDs on our network. Engineers are monitoring and in touch with the upstream carrier engineers.
Posted Nov 30, 2021 - 16:54 EST
This incident affected: Telephony (U.S. Inbound DID).