Intermittent Inbound Call Failures

Incident Report for ETHERFAX

Resolved

This incident has been resolved.
Posted Aug 22, 2025 - 21:20 EDT

Monitoring

We're continuing to monitor but results and metrics continue to be positive.
Posted Aug 22, 2025 - 18:33 EDT

Identified

ETHERFAX engineers have successfully pushed calls to an alternate path and we are seeing partial restoration. We're continuing to monitor and ensure acceptable levels of service.
Posted Aug 22, 2025 - 17:27 EDT

Update

We are continuing to investigate this issue with our carrier partner.
Posted Aug 22, 2025 - 17:08 EDT

Investigating

ETHERFAX engineering is currently investigating an increase in call failures with one of our carrier partners. At this time some inbound faxes may be failing at a higher than expected rate or callers may be encountering busy signals. The team is working with the carrier partner and is working to push calls over alternate paths.
Posted Aug 22, 2025 - 16:06 EDT
This incident affected: Telephony (U.S. Inbound DID).