Investigating Reports of Certain Calls Not Reaching etherFAX
Incident Report for ETHERFAX
Postmortem

etherFAX has received RCA for this incident from carrier.

Incident Start Date: 6/26/24 18:31 GMT
Incident End Date: 6/27/24/17:41 GMT

Cause:

  • 2 card slots on carrier switch backplane were in an unexpected state. Bad states caused the intermittent call failures.

Resolution:

  • Affected card slots were reset. Calls began completing normally.

Planned Actions:

  • Carrier has added additional logging on this hardware component to scrape, log, and alert on the trouble code.
  • Carrier NOC has implemented additional communication pathways to their engineering team.
  • Carrier Executive Team participated in a call with etherFAX leadership to discuss the outage event and lessons learned.
Posted Jul 02, 2024 - 15:03 EDT

Resolved
We are resolving this incident based on our continued monitoring along with confirmation from our carrier that the failed equipment was replaced. We expect to have a full RFO from them within 72 business hours.
Posted Jun 27, 2024 - 17:03 EDT
Update
Carrier has identified possible cause and remedied. We are continuing to test and monitor. More details to follow.
Posted Jun 27, 2024 - 13:58 EDT
Update
The etherFAX team has observed some restoration. We are still engaged and working with the carrier to ensure the issue is fully resolved.
Posted Jun 27, 2024 - 10:33 EDT
Update
The carrier ticket has been escalated to tier II and the engineering group within the affected underlying carrier. The etherFAX team remains engaged with the carrier as we await further updates.
Posted Jun 26, 2024 - 18:31 EDT
Update
etherFAX engineers remain in contact with the carrier NOC and engineers while the issue continues to be investigated.
Posted Jun 26, 2024 - 16:18 EDT
Investigating
Engineers are currently engaged with one of our underlying carriers to determine why calls to some US DIDs are not reaching the etherFAX network.
Posted Jun 26, 2024 - 15:37 EDT
This incident affected: Telephony (U.S. Inbound DID).