Northeastern US Regional Carrier Outage
Incident Report for etherFAX
Resolved
Carrier advises issue has been resolved. We are awaiting full RFO and will provide once received.
Posted 4 months ago. May 17, 2019 - 15:43 EDT
Investigating
One of our carriers is investigating a regional outage affecting inbound calls to toll numbers in the north eastern part of the United States. We're continuing to push for further updates and will provide them once we receive. At this time we have confirmed issues with numbers in LATA 120 (Maine) and parts of Massachusetts.
Posted 4 months ago. May 17, 2019 - 15:10 EDT
This incident affected: Telephony (U.S. Inbound DID).